$re = '/^[.:\\\\/a-zA-Z0-9$_-]+\.(bmp|gif|jpg|jpeg|png|psd|svg|webp)$/m';
$str = 'D:\\example\\test.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);