$re = '/(?<!^title = ){|}(?!,$)/m';
$str = 'title = {Novel breeding habitat, oviposition microhabitat, and parental care in {Bokermannohyla} caramaschii ({Anura}: {Hylidae}) in southeastern {Brazil}},';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;