package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)~[^~]{1,230}~`)
var str = `this is a test ~quote here ~ test ~quote here quote here quote here quote here quote here quote here quote here quote here quote here quote here quote here quote here quote here quote here quote here quote here quote here quote here quote here ~`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}