#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+){0,1}(254){0,1}(70|71|72|79)(\d{7})|(254){0,3}(740|741|742|743|745|746|748|757|758|759|768|769|110|111)(\d{6})$"
Local $sString = "VALID NUMBERS" & @CRLF & _
"254715228228" & @CRLF & _
"254722228228" & @CRLF & _
"254729228228" & @CRLF & _
"254745229228" & @CRLF & _
"254769229228" & @CRLF & _
"254110229228" & @CRLF & _
"254111229228" & @CRLF & _
"" & @CRLF & _
"INVALID NUMBERS" & @CRLF & _
"254730229228" & @CRLF & _
"254744229228" & @CRLF & _
"254747229228" & @CRLF & _
"254760229228" & @CRLF & _
"254100229228" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Sources: https://ca.go.ke/wp-content/uploads/2020/01/Telecommunication-Numbering-Plan-for-Kenya-Feb-2020-compressed.pdf" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")