$re = '/https?:\/\/(www[23]?.)?([A-Za-z0-9]|-|_|~|:|\?|#|[|]|@|!|$|&|\'|(|)|\*|\+|,|;|=|%[[:xdigit:]]{2})+\./';
$str = 'TODO:
La Regex suivante: ([A-Za-z0-9]|-|_|~|:|\\?|#|[|]|@|!|$|&|\'|(|)|\\*|\\+|,|;|=|%[[:xdigit:]]{2})
est valable pour l\'URL dans son entièreté.
Un nom de domaine ne peut comporter que [a-zA-Z0-9],
et le tiret qui ne peut être ni en première ni en dernière place.
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, https://www2.myd%3Eomain.com/evenements/index?sort=ville&order=ASC quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia https://www.mydomain.com/evenements/?sort=ville&order=ASC deserunt mollit anim id est laborum. Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollithttps://www3.mydomain.com/evenements?sort=ville&order=ASC anim id est laborum. Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim http://www.mydomain.com/evenements/index?sort=ville&order=ASC ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident https://admin.qwidam.com/evenements/index/sort/ville/order/ASC, sunt in culpa qui officia deserunt mollit anim id est laborum.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);