$re = '/(?:(?:;|^)\h*(?<name>[^;<>]+)\h+<(?<email>[^<>\s@;]+@[^\s@<>;]+)>|(?<email>[^<>\s@;]+@[^\s@<>;]+))/J';
$str = 'jeff <jeff@store.com>; john <john@bbaft.com>; joe@company.com; jj@abc.info; jamie <jam@sub.abc.com>
james@company.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);