package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[+\w+[\u0A47]\\\w+]]\w+`)
var str = `[[ਅਤੇ\CC_CCD]]_CCP`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}