$re = '/(\d+)x(\d++)(?!-)/m';
$str = '18x18
18x18-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);