package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\B`)
var str = `The lion roared`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}