$re = '/(?<=^|\W)([PpРр9]+[UuÙÚÛÜùúûü]+[TtТт7]+[AaÀÁÂÃÄÅĄàáâãäåąАаДд4@ª]+)(s?)(?=$|\W)/';
$str = 'putá el que lo lea putaaaááÁÁaaaa:puta🍕. hijo-de-puuta: Esto es una putada. pupupuputa puto
Pu7äs every where.PUTAPuTAaaa-PûTA. Había unos cuantos hijos de puutaááaaó puta
lalal putaaa7 que te put@sñññ que (puta) eres. puta puta puta
Reputados réputaçión -> la é y la ç son \\W
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);