$re = '/(?<=^| )\*?\w+\*?(?=$| )/m';
$str = 'ALLOW
*string* test
*string 123
string* test
string abc
DENY
*str*ing* abc *string**
*str*ing 123 *str*ing
str*ing* str*ing*
str*ing *string**
*string** *string**';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);