#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-Z0-9.!#$%&’*+\/=?^_`{|}~-]+@[a-zA-Z0-9-]+(?:\.[a-zA-Z0-9-]+)+"
Local $sString = "Envelope-to: login@site.ru" & @CRLF & _
"Delivery-date: Fri, 27 Mar 2026 09:08:10 +0300" & @CRLF & _
"Authentication-Results: dkim=pass, header.i=@1-ofd.ru" & @CRLF & _
"Received: from relay25.1-ofd.ru ([89.248.204.6])" & @CRLF & _
" by ruvip55.hostiman.ru with esmtps (TLS1.2) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384" & @CRLF & _
" (Exim 4.97.1)" & @CRLF & _
" (envelope-from <echeck@1-ofd.ru>)" & @CRLF & _
" id 1w60MX-000000007vc-3Zsb" & @CRLF & _
" for login@site.ru;" & @CRLF & _
" Fri, 27 Mar 2026 09:08:10 +0300" & @CRLF & _
"DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=1-ofd.ru; s=mail;" & @CRLF & _
" t=1774591685; bh=0o5X4pC1tr0unQQRyYpBU6TNm61Nwax1i1/3IcnrEtg=;" & @CRLF & _
" h=Date:from:reply-to:to:Subject;" & @CRLF & _
" b=PTMljcDJ3gVE0T6rQGcPrjSD0J9wF8l3o5MrWat0Pnagep+qDq42X/ZWJLpjdwM12" & @CRLF & _
" 0fCF9SocQ0kdQzOZ6TM4/ehnUdG3jYkWwvT9Bg7PAJJJBlrmoykfT2kSGGAcuSbJbP" & @CRLF & _
" KvjCHGADs9Wi1jEN3DTiJvKfYs+AR/piI0bBlcXA=" & @CRLF & _
"Date: Fri, 27 Mar 2026 09:08:04 +0300 (MSK)" & @CRLF & _
"from: =?UTF-8?B?0KfQtdC6INC4INC/0L7QtNCw0YDQvtC6?=<echeck@1-ofd.ru>" & @CRLF & _
"reply-to: echeck@1-ofd.ru" & @CRLF & _
"to: login@site.ru" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")