using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^to: )[a-zA-Z0-9.!#$%&’*+\/=?^_`{|}~-]+@[a-zA-Z0-9-]+(?:\.[a-zA-Z0-9-]+)+";
string input = @"Envelope-to: login@site.ru
Delivery-date: Fri, 27 Mar 2026 09:08:10 +0300
Authentication-Results: dkim=pass, header.i=@1-ofd.ru
Received: from relay25.1-ofd.ru ([89.248.204.6])
by ruvip55.hostiman.ru with esmtps (TLS1.2) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
(Exim 4.97.1)
(envelope-from <echeck@1-ofd.ru>)
id 1w60MX-000000007vc-3Zsb
for login@site.ru;
Fri, 27 Mar 2026 09:08:10 +0300
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=1-ofd.ru; s=mail;
t=1774591685; bh=0o5X4pC1tr0unQQRyYpBU6TNm61Nwax1i1/3IcnrEtg=;
h=Date:from:reply-to:to:Subject;
b=PTMljcDJ3gVE0T6rQGcPrjSD0J9wF8l3o5MrWat0Pnagep+qDq42X/ZWJLpjdwM12
0fCF9SocQ0kdQzOZ6TM4/ehnUdG3jYkWwvT9Bg7PAJJJBlrmoykfT2kSGGAcuSbJbP
KvjCHGADs9Wi1jEN3DTiJvKfYs+AR/piI0bBlcXA=
Date: Fri, 27 Mar 2026 09:08:04 +0300 (MSK)
from: =?UTF-8?B?0KfQtdC6INC4INC/0L7QtNCw0YDQvtC6?=<echeck@1-ofd.ru>
reply-to: echeck@1-ofd.ru
to: login@site.ru
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}