# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[A-Z]\S*\.[^\S\r\n]+[A-Z]|(?:^|[.!?][\t ]+)([A-Z]\S*)"
test_str = ("We went to Dr. Smith's office\n\n"
"This is a proper sentence. It is followed by another sentence. What happens when an abbreviation like NASA enters the scene? What about N.A.S.A with the dots in between?\n\n"
"It is NASA! No one will convince me otherwise!\n\n"
"N.A.S.A. at the start of a sentence? N.A.S.A. immediately after?\n"
"At the end of the sentence: NASA. But also with the dots: N.A.S.A. Filler sentence here.\n\n"
"The compromise of catching situations like Dr. Smith is that words at the end of a sentence cannot start with a capital letter.\n\n"
"While This Regex Doesn't Match Every Word As The Start Of A Sentence Here, It Won't Detect The Start Of The Next Sentence. Case in point.\n\n\n"
"Abbreviations like LIKE currently pose a problem.\n\n"
"The second regex has false negatives: it will fail to match `So` in `This is sentence is English. So is this one.`\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.