$re = '/\d++(?:\.\d+)?(?=\s*руб\.)/';
$str = 'Бронирование № 372 12343.22 от 24 июня 21. Стоимость проживания 1000.32 руб. а так же комиссия в размере 500 руб.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);