re = /(?<!\\)(?:\\\\)*\K\./m
str = 'two slashes: \\\\\\\\.one period: \\..line and a dot: \\\\\\.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end