re = /^(?=[MDCLXVI])M*(C[MD]|D?C{0,3})(X[CL]|L?X{0,3})(I[XV]|V?I{0,3})$/m
str = 'XXX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end