const regex = /(((DC|MB)\d{2}[-]\d{2}[-]\d{2})|(CN0\d{1})|(SYSA)|(ppag)|(METR))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((DC|MB)\\d{2}[-]\\d{2}[-]\\d{2})|(CN0\\d{1})|(SYSA)|(ppag)|(METR))', 'g')
const str = `DC00-01-14 blabla blabla MB00-07-10 blublu CN03 bli BLI2454 bli bli CN02 bloblo bloblo bloblo SYSA bloublou bloublou bloublou CN06 blaiblai fgdf+-*blaiblai blaiblai METR bly
bly blybly blybly ppag blublib/12-+kjflouBFD 454`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}