const regex = /(^|[^_])_(?!_)((?:[^]*?[^_])?)_(?!_)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^_])_(?!_)((?:[^]*?[^_])?)_(?!_)', 'gm')
const str = `_bold_
__bold__
`;
const subst = `$1<em>$2</em>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);