import re
regex = re.compile(r"%5B%22[^ ]+%22%2C1%2C%22%22%2C%22(.*)%22%5D@googleapis.com", flags=re.MULTILINE)
test_str = ("--batch7717900821286095411\n\n"
"Content-Type: application/http\n\n"
"Content-Transfer-Encoding: binary\n\n"
"Content-ID: <batch7717900821286095411+%5B%22124I1eovpUwJR2Ce6sb4LbtSHgri5BJHM%22%2C1%2C%22%22%2C%22testuser1%40gatewaybeatle%2Ecom%22%5D@googleapis.com>\n\n\n\n"
"POST /drive/v2internal/files/124I1eovpUwJR2Ce6sb4LbtSHgri5BJHM/permissions?fields=id%2Cname%2CemailAddress%2Crole%2CphotoLink%2CadditionalRoles%2Ctype%2CwithLink%2Cdomain%2CpermissionDetails%2Ccapabilities%2CselectableRoles%2Cview%2CinapplicableReason%2CexpirationDate%2Cdeleted%2CaudienceId%2CcustomerId%2CisStale&confirmed=false&sendNotificationEmails=true&languageCode=en&supportsTeamDrives=true&alt=json&key=AIzaSyC4JjdyoZPBZbhiXypJRsdhGicms9lgzoA\n\n"
"X-JavaScript-User-Agent: google-api-javascript-client/1.1.0\n\n"
"X-Requested-With: XMLHttpRequest\n\n"
"Content-Type: application/json\n\n"
"X-Goog-Encode-Response-If-Executable: base64\n\n"
"X-Goog-AuthUser: 0\n\n"
"Authorization: SAPISIDHASH 1589278246_b2c8377eb040624a399411f2e7cea308088b32b3\n\n"
"X-ClientDetails: appVersion=5.0%20(Windows)&platform=Win32&userAgent=Mozilla%2F5.0%20(Windows%20NT%2010.0%3B%20WOW64%3B%20rv%3A68.0)%20Gecko%2F20100101%20Firefox%2F68.0\n\n\n\n"
"{\"additionalRoles\":[],\"role\":\"writer\",\"type\":\"user\",\"value\":\"testuser1@gatewaybeatle.com\"}\n\n"
"--batch7717900821286095411\n\n"
"Content-Type: application/http\n\n"
"Content-Transfer-Encoding: binary\n\n"
"Content-ID: <batch7717900821286095411+%5B%221fbbSghayZHhIJBTSK-ZqQT6_gt_bfcpi%22%2C1%2C%22%22%2C%22testuser1%40gatewaybeatle%2Ecom%22%5D@googleapis.com>\n\n\n\n"
"POST /drive/v2internal/files/1fbbSghayZHhIJBTSK-ZqQT6_gt_bfcpi/permissions?fields=id%2Cname%2CemailAddress%2Crole%2CphotoLink%2CadditionalRoles%2Ctype%2CwithLink%2Cdomain%2CpermissionDetails%2Ccapabilities%2CselectableRoles%2Cview%2CinapplicableReason%2CexpirationDate%2Cdeleted%2CaudienceId%2CcustomerId%2CisStale&confirmed=false&sendNotificationEmails=true&languageCode=en&supportsTeamDrives=true&alt=json&key=AIzaSyC4JjdyoZPBZbhiXypJRsdhGicms9lgzoA\n\n"
"X-JavaScript-User-Agent: google-api-javascript-client/1.1.0\n\n"
"X-Requested-With: XMLHttpRequest\n\n"
"Content-Type: application/json\n\n"
"X-Goog-Encode-Response-If-Executable: base64\n\n"
"X-Goog-AuthUser: 0\n\n"
"Authorization: SAPISIDHASH 1589278246_b2c8377eb040624a399411f2e7cea308088b32b3\n\n"
"X-ClientDetails: appVersion=5.0%20(Windows)&platform=Win32&userAgent=Mozilla%2F5.0%20(Windows%20NT%2010.0%3B%20WOW64%3B%20rv%3A68.0)%20Gecko%2F20100101%20Firefox%2F68.0\n\n\n\n"
"{\"additionalRoles\":[],\"role\":\"writer\",\"type\":\"user\",\"value\":\"testuser1@gatewaybeatle.com\"}\n\n"
"--batch7717900821286095411\n\n"
"Content-Type: application/http\n\n"
"Content-Transfer-Encoding: binary\n\n"
"Content-ID: <batch7717900821286095411+%5B%221n89G34zW8jBWWCobxLCjdhlds-vjDNmR%22%2C1%2C%22%22%2C%22testuser1%40gatewaybeatle%2Ecom%22%5D@googleapis.com>\n\n\n\n"
"POST /drive/v2internal/files/1n89G34zW8jBWWCobxLCjdhlds-vjDNmR/permissions?fields=id%2Cname%2CemailAddress%2Crole%2CphotoLink%2CadditionalRoles%2Ctype%2CwithLink%2Cdomain%2CpermissionDetails%2Ccapabilities%2CselectableRoles%2Cview%2CinapplicableReason%2CexpirationDate%2Cdeleted%2CaudienceId%2CcustomerId%2CisStale&confirmed=false&sendNotificationEmails=true&languageCode=en&supportsTeamDrives=true&alt=json&key=AIzaSyC4JjdyoZPBZbhiXypJRsdhGicms9lgzoA\n\n"
"X-JavaScript-User-Agent: google-api-javascript-client/1.1.0\n\n"
"X-Requested-With: XMLHttpRequest\n\n"
"Content-Type: application/json\n\n"
"X-Goog-Encode-Response-If-Executable: base64\n\n"
"X-Goog-AuthUser: 0\n\n"
"Authorization: SAPISIDHASH 1589278246_b2c8377eb040624a399411f2e7cea308088b32b3\n\n"
"X-ClientDetails: appVersion=5.0%20(Windows)&platform=Win32&userAgent=Mozilla%2F5.0%20(Windows%20NT%2010.0%3B%20WOW64%3B%20rv%3A68.0)%20Gecko%2F20100101%20Firefox%2F68.0\n\n\n\n"
"{\"additionalRoles\":[],\"role\":\"writer\",\"type\":\"user\",\"value\":\"testuser1@gatewaybeatle.com\"}\n\n"
"--batch7717900821286095411\n\n"
"Content-Type: application/http\n\n"
"Content-Transfer-Encoding: binary\n\n"
"Content-ID: <batch7717900821286095411+%5B%22124I1eovpUwJR2Ce6sb4LbtSHgri5BJHM%22%2C1%2C%22%22%2C%22sanityuser%40gatewaybeatle%2Ecom%22%5D@googleapis.com>\n\n\n\n"
"POST /drive/v2internal/files/124I1eovpUwJR2Ce6sb4LbtSHgri5BJHM/permissions?fields=id%2Cname%2CemailAddress%2Crole%2CphotoLink%2CadditionalRoles%2Ctype%2CwithLink%2Cdomain%2CpermissionDetails%2Ccapabilities%2CselectableRoles%2Cview%2CinapplicableReason%2CexpirationDate%2Cdeleted%2CaudienceId%2CcustomerId%2CisStale&confirmed=false&sendNotificationEmails=true&languageCode=en&supportsTeamDrives=true&alt=json&key=AIzaSyC4JjdyoZPBZbhiXypJRsdhGicms9lgzoA\n\n"
"X-JavaScript-User-Agent: google-api-javascript-client/1.1.0\n\n"
"X-Requested-With: XMLHttpRequest\n\n"
"Content-Type: application/json\n\n"
"X-Goog-Encode-Response-If-Executable: base64\n\n"
"X-Goog-AuthUser: 0\n\n"
"Authorization: SAPISIDHASH 1589278246_b2c8377eb040624a399411f2e7cea308088b32b3\n\n"
"X-ClientDetails: appVersion=5.0%20(Windows)&platform=Win32&userAgent=Mozilla%2F5.0%20(Windows%20NT%2010.0%3B%20WOW64%3B%20rv%3A68.0)%20Gecko%2F20100101%20Firefox%2F68.0\n\n\n\n"
"{\"additionalRoles\":[],\"role\":\"writer\",\"type\":\"user\",\"value\":\"sanityuser@gatewaybeatle.com\"}\n\n"
"--batch7717900821286095411\n\n"
"Content-Type: application/http\n\n"
"Content-Transfer-Encoding: binary\n\n"
"Content-ID: <batch7717900821286095411+%5B%221fbbSghayZHhIJBTSK-ZqQT6_gt_bfcpi%22%2C1%2C%22%22%2C%22sanityuser%40gatewaybeatle%2Ecom%22%5D@googleapis.com>\n\n\n\n"
"POST /drive/v2internal/files/1fbbSghayZHhIJBTSK-ZqQT6_gt_bfcpi/permissions?fields=id%2Cname%2CemailAddress%2Crole%2CphotoLink%2CadditionalRoles%2Ctype%2CwithLink%2Cdomain%2CpermissionDetails%2Ccapabilities%2CselectableRoles%2Cview%2CinapplicableReason%2CexpirationDate%2Cdeleted%2CaudienceId%2CcustomerId%2CisStale&confirmed=false&sendNotificationEmails=true&languageCode=en&supportsTeamDrives=true&alt=json&key=AIzaSyC4JjdyoZPBZbhiXypJRsdhGicms9lgzoA\n\n"
"X-JavaScript-User-Agent: google-api-javascript-client/1.1.0\n\n"
"X-Requested-With: XMLHttpRequest\n\n"
"Content-Type: application/json\n\n"
"X-Goog-Encode-Response-If-Executable: base64\n\n"
"X-Goog-AuthUser: 0\n\n"
"Authorization: SAPISIDHASH 1589278246_b2c8377eb040624a399411f2e7cea308088b32b3\n\n"
"X-ClientDetails: appVersion=5.0%20(Windows)&platform=Win32&userAgent=Mozilla%2F5.0%20(Windows%20NT%2010.0%3B%20WOW64%3B%20rv%3A68.0)%20Gecko%2F20100101%20Firefox%2F68.0\n\n\n\n"
"{\"additionalRoles\":[],\"role\":\"writer\",\"type\":\"user\",\"value\":\"sanityuser@gatewaybeatle.com\"}\n\n"
"--batch7717900821286095411\n\n"
"Content-Type: application/http\n\n"
"Content-Transfer-Encoding: binary\n\n"
"Content-ID: <batch7717900821286095411+%5B%221n89G34zW8jBWWCobxLCjdhlds-vjDNmR%22%2C1%2C%22%22%2C%22sanityuser%40gatewaybeatle%2Ecom%22%5D@googleapis.com>\n\n\n\n"
"POST /drive/v2internal/files/1n89G34zW8jBWWCobxLCjdhlds-vjDNmR/permissions?fields=id%2Cname%2CemailAddress%2Crole%2CphotoLink%2CadditionalRoles%2Ctype%2CwithLink%2Cdomain%2CpermissionDetails%2Ccapabilities%2CselectableRoles%2Cview%2CinapplicableReason%2CexpirationDate%2Cdeleted%2CaudienceId%2CcustomerId%2CisStale&confirmed=false&sendNotificationEmails=true&languageCode=en&supportsTeamDrives=true&alt=json&key=AIzaSyC4JjdyoZPBZbhiXypJRsdhGicms9lgzoA\n\n"
"X-JavaScript-User-Agent: google-api-javascript-client/1.1.0\n\n"
"X-Requested-With: XMLHttpRequest\n\n"
"Content-Type: application/json\n\n"
"X-Goog-Encode-Response-If-Executable: base64\n\n"
"X-Goog-AuthUser: 0\n\n"
"Authorization: SAPISIDHASH 1589278246_b2c8377eb040624a399411f2e7cea308088b32b3\n\n"
"X-ClientDetails: appVersion=5.0%20(Windows)&platform=Win32&userAgent=Mozilla%2F5.0%20(Windows%20NT%2010.0%3B%20WOW64%3B%20rv%3A68.0)%20Gecko%2F20100101%20Firefox%2F68.0\n\n\n\n"
"{\"additionalRoles\":[],\"role\":\"writer\",\"type\":\"user\",\"value\":\"sanityuser@gatewaybeatle.com\"}\n\n"
"--batch7717900821286095411\n\n"
"Content-Type: application/http\n\n"
"Content-Transfer-Encoding: binary\n\n"
"Content-ID: <batch7717900821286095411+%5B%22124I1eovpUwJR2Ce6sb4LbtSHgri5BJHM%22%2C1%2C%22%22%2C%22admin%40gatewaybeatle%2Ecom%22%5D@googleapis.com>\n\n\n\n"
"POST /drive/v2internal/files/124I1eovpUwJR2Ce6sb4LbtSHgri5BJHM/permissions?fields=id%2Cname%2CemailAddress%2Crole%2CphotoLink%2CadditionalRoles%2Ctype%2CwithLink%2Cdomain%2CpermissionDetails%2Ccapabilities%2CselectableRoles%2Cview%2CinapplicableReason%2CexpirationDate%2Cdeleted%2CaudienceId%2CcustomerId%2CisStale&confirmed=false&sendNotificationEmails=true&languageCode=en&supportsTeamDrives=true&alt=json&key=AIzaSyC4JjdyoZPBZbhiXypJRsdhGicms9lgzoA\n\n"
"X-JavaScript-User-Agent: google-api-javascript-client/1.1.0\n\n"
"X-Requested-With: XMLHttpRequest\n\n"
"Content-Type: application/json\n\n"
"X-Goog-Encode-Response-If-Executable: base64\n\n"
"X-Goog-AuthUser: 0\n\n"
"Authorization: SAPISIDHASH 1589278246_b2c8377eb040624a399411f2e7cea308088b32b3\n\n"
"X-ClientDetails: appVersion=5.0%20(Windows)&platform=Win32&userAgent=Mozilla%2F5.0%20(Windows%20NT%2010.0%3B%20WOW64%3B%20rv%3A68.0)%20Gecko%2F20100101%20Firefox%2F68.0\n\n\n\n"
"{\"additionalRoles\":[],\"role\":\"writer\",\"type\":\"user\",\"value\":\"admin@gatewaybeatle.com\"}\n\n"
"--batch7717900821286095411\n\n"
"Content-Type: application/http\n\n"
"Content-Transfer-Encoding: binary\n\n"
"Content-ID: <batch7717900821286095411+%5B%221fbbSghayZHhIJBTSK-ZqQT6_gt_bfcpi%22%2C1%2C%22%22%2C%22admin%40gatewaybeatle%2Ecom%22%5D@googleapis.com>\n\n\n\n"
"POST /drive/v2internal/files/1fbbSghayZHhIJBTSK-ZqQT6_gt_bfcpi/permissions?fields=id%2Cname%2CemailAddress%2Crole%2CphotoLink%2CadditionalRoles%2Ctype%2CwithLink%2Cdomain%2CpermissionDetails%2Ccapabilities%2CselectableRoles%2Cview%2CinapplicableReason%2CexpirationDate%2Cdeleted%2CaudienceId%2CcustomerId%2CisStale&confirmed=false&sendNotificationEmails=true&languageCode=en&supportsTeamDrives=true&alt=json&key=AIzaSyC4JjdyoZPBZbhiXypJRsdhGicms9lgzoA\n\n"
"X-JavaScript-User-Agent: google-api-javascript-client/1.1.0\n\n"
"X-Requested-With: XMLHttpRequest\n\n"
"Content-Type: application/json\n\n"
"X-Goog-Encode-Response-If-Executable: base64\n\n"
"X-Goog-AuthUser: 0\n\n"
"Authorization: SAPISIDHASH 1589278246_b2c8377eb040624a399411f2e7cea308088b32b3\n\n"
"X-ClientDetails: appVersion=5.0%20(Windows)&platform=Win32&userAgent=Mozilla%2F5.0%20(Windows%20NT%2010.0%3B%20WOW64%3B%20rv%3A68.0)%20Gecko%2F20100101%20Firefox%2F68.0\n\n\n\n"
"{\"additionalRoles\":[],\"role\":\"writer\",\"type\":\"user\",\"value\":\"admin@gatewaybeatle.com\"}\n\n"
"--batch7717900821286095411\n\n"
"Content-Type: application/http\n\n"
"Content-Transfer-Encoding: binary\n\n"
"Content-ID: <batch7717900821286095411+%5B%221n89G34zW8jBWWCobxLCjdhlds-vjDNmR%22%2C1%2C%22%22%2C%22admin%40gatewaybeatle%2Ecom%22%5D@googleapis.com>\n\n\n\n"
"POST /drive/v2internal/files/1n89G34zW8jBWWCobxLCjdhlds-vjDNmR/permissions?fields=id%2Cname%2CemailAddress%2Crole%2CphotoLink%2CadditionalRoles%2Ctype%2CwithLink%2Cdomain%2CpermissionDetails%2Ccapabilities%2CselectableRoles%2Cview%2CinapplicableReason%2CexpirationDate%2Cdeleted%2CaudienceId%2CcustomerId%2CisStale&confirmed=false&sendNotificationEmails=true&languageCode=en&supportsTeamDrives=true&alt=json&key=AIzaSyC4JjdyoZPBZbhiXypJRsdhGicms9lgzoA\n\n"
"X-JavaScript-User-Agent: google-api-javascript-client/1.1.0\n\n"
"X-Requested-With: XMLHttpRequest\n\n"
"Content-Type: application/json\n\n"
"X-Goog-Encode-Response-If-Executable: base64\n\n"
"X-Goog-AuthUser: 0\n\n"
"Authorization: SAPISIDHASH 1589278246_b2c8377eb040624a399411f2e7cea308088b32b3\n\n"
"X-ClientDetails: appVersion=5.0%20(Windows)&platform=Win32&userAgent=Mozilla%2F5.0%20(Windows%20NT%2010.0%3B%20WOW64%3B%20rv%3A68.0)%20Gecko%2F20100101%20Firefox%2F68.0\n\n\n\n"
"{\"additionalRoles\":[],\"role\":\"writer\",\"type\":\"user\",\"value\":\"admin@gatewaybeatle.com\"}\n\n"
"--batch7717900821286095411\n\n"
"Content-Type: application/http\n\n"
"Content-Transfer-Encoding: binary\n\n"
"Content-ID: <batch7717900821286095411+%5B%22124I1eovpUwJR2Ce6sb4LbtSHgri5BJHM%22%2C1%2C%22%22%2C%22feadmin%40gatewaybeatle%2Ecom%22%5D@googleapis.com>\n\n\n\n"
"POST /drive/v2internal/files/124I1eovpUwJR2Ce6sb4LbtSHgri5BJHM/permissions?fields=id%2Cname%2CemailAddress%2Crole%2CphotoLink%2CadditionalRoles%2Ctype%2CwithLink%2Cdomain%2CpermissionDetails%2Ccapabilities%2CselectableRoles%2Cview%2CinapplicableReason%2CexpirationDate%2Cdeleted%2CaudienceId%2CcustomerId%2CisStale&confirmed=false&sendNotificationEmails=true&languageCode=en&supportsTeamDrives=true&alt=json&key=AIzaSyC4JjdyoZPBZbhiXypJRsdhGicms9lgzoA\n\n"
"X-JavaScript-User-Agent: google-api-javascript-client/1.1.0\n\n"
"X-Requested-With: XMLHttpRequest\n\n"
"Content-Type: application/json\n\n"
"X-Goog-Encode-Response-If-Executable: base64\n\n"
"X-Goog-AuthUser: 0\n\n"
"Authorization: SAPISIDHASH 1589278246_b2c8377eb040624a399411f2e7cea308088b32b3\n\n"
"X-ClientDetails: appVersion=5.0%20(Windows)&platform=Win32&userAgent=Mozilla%2F5.0%20(Windows%20NT%2010.0%3B%20WOW64%3B%20rv%3A68.0)%20Gecko%2F20100101%20Firefox%2F68.0\n\n\n\n"
"{\"additionalRoles\":[],\"role\":\"writer\",\"type\":\"user\",\"value\":\"feadmin@gatewaybeatle.com\"}\n\n"
"--batch7717900821286095411\n\n"
"Content-Type: application/http\n\n"
"Content-Transfer-Encoding: binary\n\n"
"Content-ID: <batch7717900821286095411+%5B%221fbbSghayZHhIJBTSK-ZqQT6_gt_bfcpi%22%2C1%2C%22%22%2C%22feadmin%40gatewaybeatle%2Ecom%22%5D@googleapis.com>\n\n\n\n"
"POST /drive/v2internal/files/1fbbSghayZHhIJBTSK-ZqQT6_gt_bfcpi/permissions?fields=id%2Cname%2CemailAddress%2Crole%2CphotoLink%2CadditionalRoles%2Ctype%2CwithLink%2Cdomain%2CpermissionDetails%2Ccapabilities%2CselectableRoles%2Cview%2CinapplicableReason%2CexpirationDate%2Cdeleted%2CaudienceId%2CcustomerId%2CisStale&confirmed=false&sendNotificationEmails=true&languageCode=en&supportsTeamDrives=true&alt=json&key=AIzaSyC4JjdyoZPBZbhiXypJRsdhGicms9lgzoA\n\n"
"X-JavaScript-User-Agent: google-api-javascript-client/1.1.0\n\n"
"X-Requested-With: XMLHttpRequest\n\n"
"Content-Type: application/json\n\n"
"X-Goog-Encode-Response-If-Executable: base64\n\n"
"X-Goog-AuthUser: 0\n\n"
"Authorization: SAPISIDHASH 1589278246_b2c8377eb040624a399411f2e7cea308088b32b3\n\n"
"X-ClientDetails: appVersion=5.0%20(Windows)&platform=Win32&userAgent=Mozilla%2F5.0%20(Windows%20NT%2010.0%3B%20WOW64%3B%20rv%3A68.0)%20Gecko%2F20100101%20Firefox%2F68.0\n\n\n\n"
"{\"additionalRoles\":[],\"role\":\"writer\",\"type\":\"user\",\"value\":\"feadmin@gatewaybeatle.com\"}\n\n"
"--batch7717900821286095411\n\n"
"Content-Type: application/http\n\n"
"Content-Transfer-Encoding: binary\n\n"
"Content-ID: <batch7717900821286095411+%5B%221n89G34zW8jBWWCobxLCjdhlds-vjDNmR%22%2C1%2C%22%22%2C%22feadmin%40gatewaybeatle%2Ecom%22%5D@googleapis.com>\n\n\n\n"
"POST /drive/v2internal/files/1n89G34zW8jBWWCobxLCjdhlds-vjDNmR/permissions?fields=id%2Cname%2CemailAddress%2Crole%2CphotoLink%2CadditionalRoles%2Ctype%2CwithLink%2Cdomain%2CpermissionDetails%2Ccapabilities%2CselectableRoles%2Cview%2CinapplicableReason%2CexpirationDate%2Cdeleted%2CaudienceId%2CcustomerId%2CisStale&confirmed=false&sendNotificationEmails=true&languageCode=en&supportsTeamDrives=true&alt=json&key=AIzaSyC4JjdyoZPBZbhiXypJRsdhGicms9lgzoA\n\n"
"X-JavaScript-User-Agent: google-api-javascript-client/1.1.0\n\n"
"X-Requested-With: XMLHttpRequest\n\n"
"Content-Type: application/json\n\n"
"X-Goog-Encode-Response-If-Executable: base64\n\n"
"X-Goog-AuthUser: 0\n\n"
"Authorization: SAPISIDHASH 1589278246_b2c8377eb040624a399411f2e7cea308088b32b3\n\n"
"X-ClientDetails: appVersion=5.0%20(Windows)&platform=Win32&userAgent=Mozilla%2F5.0%20(Windows%20NT%2010.0%3B%20WOW64%3B%20rv%3A68.0)%20Gecko%2F20100101%20Firefox%2F68.0\n\n\n\n"
"{\"additionalRoles\":[],\"role\":\"writer\",\"type\":\"user\",\"value\":\"feadmin@gatewaybeatle.com\"}\n\n"
"--batch7717900821286095411--\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")