using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"load_date\\\"":\s+\\\""(?<load_date>[^\\]+)";
string input = @" {""_c0"":{""0"":""["",""1"":"" {"",""2"":"" \""table_name\"": \""pc_dwh_rdv.gdh_ls2lo_s99\"",""3"":"" \""deleted_count\"": 18"",""4"":"" \""redelivered_count\"": 0"",""5"":"" \""load_date\"": \""2023-07-27\"",""6"":"" }"",""7"":"" {"",""8"":"" \""table_name\"": \""pc_dwh_rdv.gdh_spar_s99\"",""9"":"" \""deleted_count\"": 8061"",""10"":"" \""redelivered_count\"": 1"",""11"":"" \""load_date\"": \""2023-07-27\"",""12"":"" }"",""13"":"" {"",""14"":"" \""table_name\"": \""pc_dwh_rdv.gdh_tf3tx_s99\"",""15"":"" \""deleted_count\"": 366619"",""16"":"" \""redelivered_count\"": 0"",""17"":"" \""load_date\"": \""2023-07-27\"",""18"":"" }"",""19"":"" {"",""20"":"" \""table_name\"": \""pc_dwh_rdv.gdh_wechsel_s99\"",""21"":"" \""deleted_count\"": 2"",""22"":"" \""redelivered_count\"": 0"",""23"":"" \""load_date\"": \""2023-07-27\"",""24"":"" }"",""25"":"" {"",""26"":"" \""table_name\"": \""pc_dwh_rdv.gdh_revolvingcreditcard_s99\"",""27"":"" \""deleted_count\"": 1285"",""28"":"" \""redelivered_count\"": 0"",""29"":"" \""load_date\"": \""2023-07-27\"",""30"":"" }"",""31"":"" {"",""32"":"" \""table_name\"": \""pc_dwh_rdv.gdh_phd_s99\"",""33"":"" \""deleted_count\"": 2484"",""34"":"" \""redelivered_count\"": 204"",""35"":"" \""load_date\"": \""2023-07-27\"",""36"":"" }"",""37"":"" {"",""38"":"" \""table_name\"": \""pc_dwh_rdv.gdh_npk_s99\"",""39"":"" \""deleted_count\"": 1705"",""40"":"" \""redelivered_count\"": 0"",""41"":"" \""load_date\"": \""2023-07-27\"",""42"":"" }"",""43"":"" {"",""44"":"" \""table_name\"": \""pc_dwh_rdv.gdh_npk_s98\"",""45"":"" \""deleted_count\"": 1517"",""46"":"" \""redelivered_count\"": 0"",""47"":"" \""load_date\"": \""2023-07-27\"",""48"":"" }"",""49"":"" {"",""50"":"" \""table_name\"": \""pc_dwh_rdv.gdh_kontokorrent_s99\"",""51"":"" \""deleted_count\"": 12998"",""52"":"" \""redelivered_count\"": 0"",""53"":"" \""load_date\"": \""2023-07-27\"",""54"":"" }"",""55"":"" {"",""56"":"" \""table_name\"": \""pc_dwh_rdv.gdh_gds_s99\"",""57"":"" \""deleted_count\"": 13"",""58"":"" \""redelivered_count\"": 0"",""59"":"" \""load_date\"": \""2023-07-27\"",""60"":"" }"",""61"":"" {"",""62"":"" \""table_name\"": \""pc_dwh_rdv.gdh_dszins_s99\"",""63"":"" \""deleted_count\"": 57"",""64"":"" \""redelivered_count\"": 0"",""65"":"" \""load_date\"": \""2023-07-27\"",""66"":"" }"",""67"":"" {"",""68"":"" \""table_name\"": \""pc_dwh_rdv_gdh_monat.gdh_phd_izr_monthly_s99\"",""69"":"" \""deleted_count\"": 1315"",""70"":"" \""redelivered_count\"": 0"",""71"":"" \""load_date\"": \""2023-07-27\"",""72"":"" }"",""73"":""]""}}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}