$re = '/mainTitle_.+?">([^<]+).+?secondaryTitle_.+?">([^<]+).+?secondaryText_.+?->([^<]+)/m';
$str = '<span class="styles_mainTitle__IFQyZ styles_activeMovieTittle__kJdJj" data-tid="4502216a">Зеленая миля</span></div><div class="desktop-list-main-info_secondaryTitleSlot__mc0mI"><span class="desktop-list-main-info_secondaryTitle__ighTt">The Green Mile</span><span class="desktop-list-main-info_secondaryText__M_aus">, <!-- -->1999, 189 мин.</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);