$re = '/(?<!очень )хороший/m';
$str = 'один очень хороший два три хороший четыре пять очень хороший шесть семь';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);