package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\(\(\d+(?:\.\d+)? \d+\)(?:\s*\(\d+(?:\.\d+)? \d+\))*\)$`)
var str = `((1.0 4) (2.0 5) (10.0 8))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}