$re = '/^\d+(?: [A-Z][a-z]*)+$/m';
$str = '124 Main Street
124 main Street
124 Main street';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);