$re = '/\B\'\b|\b\'\B/';
$str = 'apple
\'orange
banana\'
joe\'s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);