$re = '/^6(?:011|5[0-9]{2})(?:[0-9]{3}){4,5}$/m';
$str = '6011111111111117
6011000990139424
60110009901394245
6011000990139424123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);