re = /\b\w{4}\b/m
str = 'Lorem colour ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, color quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
single
Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt coloursmollit anim id est laborum colors.
words
Lorem colour ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
Ut enim ad minim veniam, color quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
single
Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt coloursmollit anim id est laborum colors.
words'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end