$re = '/.+? (?=От:)/m';
$str = 'Комментарий из почты
От: admin
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);