$re = '/\b\d{4}\b/m';
$str = 'abcd1245 784563 1234 98756 kfg7456178';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);