# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^|\b(?<!\.))(?:1?\d?\d|2[0-4]\d|25[0-5])(?:\.(?:1?\d?\d|2[0-4]\d|25[0-5])){3}(?=$|[^\w.])|(?:^|\b(?<!\.))(?:1?\d?\d|2[0-4]\d|25[0-5])(?:\.(?:1?\d?\d|2[0-4]\d|25[0-5]))(?:\.\W.*)(?:1?\d?\d|2[0-4]\d|25[0-5])|(?:1?\d?\d|2[0-4]\d|25[0-5])(?:\.(?:1?\d?\d|2[0-4]\d|25[0-5])){2}(?:\.[\W].+)(?:\})"
test_str = ("My input string & constraints are as follows :\n\n"
" IPv4 Range : 0.0.0.0 to 255.255.255.255 55.123.99.988 256.1.1.1\n"
" IPv4 address may / may not be present in the string\n"
" Valid Examples : this is an ip & this is an ip 200.100.2.32\n"
" String may start with IPv4 address 10.250.{{ number*2 }}.5 sdsd\n"
" Valid Examples : 10.250.5.{{ number*2 }} asdf\n"
"200.100.2.{{ number*2 }} is an ip | Output : ['200.100.2.32']\n"
" Invalid Examples :\n"
"200.100.2.32is an ip | Output : []\n"
" String may end with IPv4 address\n"
" Valid Examples : the ip is 200.100.2.32\n"
"Output : ['200.100.2.32']\n"
" Invalid Examples : the ip is200.100.2.32\n"
"Output : []\n"
" String may contain an IPv4 address in the middle, and if it does - there will a space before and after the IPv4 address.\n"
" Valid Examples : the ip is 200.100.2.32 and it is ipv4 | Output : ['200.100.2.32']\n"
" Valid Examples : the ip is 200.100.2.32and it is ipv4 | Output : []\n"
" Multiple IPs may be present in a single string\n"
" Valid Examples : 200.100.2.32 100.50.1.16 | Output : ['200.100.2.32', '100.50.1.16']\n"
" Invalid Examples : 200.100.2.32.100.50.1.16 | Output : []\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.