// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\s(L.?T.?D.?A.?|E.?I.?R.?L.?|S.?P.?A.?)|(LI?MI?T[DA]{0,3})|(S[\.\s]{0,2}?A\.?)$").unwrap();
let string = "CONSTRUCTORA CORACEROS LIMITADA
SERVICIOS EXTERNOS SARE LTDA
SOCIEDAD COMERCIAL DE REPRESENTACIONES LIMITADA
NGS S.A.
INTERNATIONAL SERVICE LIMITADA
DARTEL TALCA LIMITADA
EUROMERCAD S A
CARGO ENTREGA S A
DE LA FUENTE Y CARPANETTI LIMITADA
INGELAN CONSULTORES LIMITADA
CIA INMOBILIARIA Y DE INVERSIONES TRICELTA LIMITADA
CHILENA DE COMPUTACION LIMITADA
ASESORIAS E INVERSIONES RPV LIMITADA
SOC AGRICOLA Y GANADERA EL MEMBRILLAR LIMITADA
R Y C CARGO LTDA
TEJIDOS TRENZATEX LIMITADA
GENIAL DISENO Y PUBLICIDAD LIMITADA
ACME ANALYTICAL LABORATORIES S A
SOC DE TRANSPORTES VALIJA Y CARGAS SERVIVAL LIMITADA
COMERCIAL E INDUSTRIAL SAN ANGEL LIMITAD
ARKADIA MUEBLES Y DECORACIONES LTDA
IMPORTADORA EXPORTADORA YARDAS LIMITADA
REPDEVAL EQUIPOS Y COMPANIA LIMITADA
AGENCIA DE ADUANAS JORGE E. CELIS CORNEJO CIA LTDA
PINTO GLAVICH INGENIERIA Y CONSTRUCCION S A
PRODUCTOS MITRE LIMITADA
IMPORTADORA Y COMERCIAL ALTEA LTDA
COMERCIAL ICOM SPA
VINA CASABLANCA S.A.
LATCAM PAGOS INTERNACIONALES S.A.
SERVICIOS DE MARKETING DIRECTO Y MERCHANDISING LIMITADA
MONTAJES OROPESA LIMITADA
AMENABAR Y ASOCIADOS TALLERES GRAFICOS S.A.
SOCIEDAD SPORT TRADE LIMITADA
VINA PIRAZZOLI LIMITADA
OPTICA NUEVA VISION LIMITADA
B & S SOLUCIONES COMPUTACIONALES LIMITADA
SOC COMERCIAL PROLABI LIMITADA
CENTRO DE COMUNICACIONES COPIAPO LIMITADA
TECNOAYSEN LTDA
COMERCIO INTERNAC REPRESENT E INV SECTRADE LIMITADA
SOC GASTRONOMICA CASABLANCA LIMITADA
SOC COMERC TRADE MARK LIMITADA
SOC COMERCIAL E INMOBILIARIA PLASTOCK LIMITADA
SOC PUBLICITARIA MORENO Y COMPANIA LIMITADA
N PRODUCCIONES LIMITADA
TECNOLOGIA Y SERVICIOS EN COMPRESORES LIMITADA
PRODUCTOS Y SERVICIOS COMPUTACIONALES LIMITADA
AERO ANDINA S A
COMERCIALIZADORA BANDELSUR LIMITADA
GLOVOX PRODUCCIONES LIMITADA
COMERCIAL LORENA GONZALEZ RAMOS E.I.R.L.
HOSPITAL & DIAGNOSTICS SUPPLIES LIMITADA
APOYO EXPRESS SERVICIOS LIMITADA
AGRICOLA LAS MERCEDES DEL LIMARI LIMITADA
ALIMENTOS DEL NORTE LIMITADA
IKONS ATN INVERSIONES LIMITADA
JULIO Y NIXON LIMITADA
SOC AGRICOLA Y COMERCIAL JERUSALEM LIMITADA
IMAGEN Y DISENO LIMITADA
XPERIENCE CONSULTORIA Y SERVICIOS COMPUTACIONALES LIMTADA
SERVICIOS PUBLICITARIOS CANAL DIRECTO LIMITADA";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}