using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:[^;<>]+;)*)(?:[^;]*(?:<|>)[^;]*;)*([^;<>]+)(?:;[^;]*(?:<|>)[^;]*)*((?:;[^;<>]+)*)(?:;[^;]*(?:<|>)[^;]*)*((?:;[^;<>]+)*)(?:;[^;]*(?:<|>)[^;]*)*((?:;[^;<>]+)*)(?:;[^;]*(?:<|>)[^;]*)*((?:;[^;<>]+)*)$";
string input = @"prov=b6a9a797-88de-95cf-705f-f04475ea4d8a; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _gid=GA1.2.19039273<28.1568202810; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; _ga=GA1.2.175<2530920.1564494>781; acct=t=YAiQ2RXtOBOG1Pf5UnKFxWZ%2bcINrjVde&s=%2btpIj7pF1GMoTVFuiDTS95VXolHih4l%2f; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499;_ym_uid=1565792005592706499;_ga=GA1.2.175<2530920.1564494>781;_ga=GA1.2.175<2530920.1564494>781;_ga=GA1.2.175<2530920.1564494>781;_ga=GA1.2.175<2530920.1564494>781;_ga=GA1.2.175<2530920.1564494>781;_ga=GA1.2.175<2530920.1564494>781; __gads=ID=fbdbf646c4f1b756:T=1564494781:S=ALNI_MaF9--jX-1UcW8INO5Pg9oENCXPJA; __qca=P0-1424341845-1564494781627; _ym_uid=1565792005592706499; _ym_d=1565792005; cc=e5a3d35ac7064d5caae23af2ce2caca0; superSecretTrackingCookie2=4efca328-421c-42e0-9426-96fbbb61cc51; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499;_gid=GA1.2.19039273<28.1568202810; acct=t=YAiQ2RXtOBOG1Pf5UnKFxWZ%2bcINrjVde&s=%2btpIj7pF1GMoTVFuiDTS95VXolHih4l%2f; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499;_gid=GA1.2.19039273<28.1568202810;_gid=GA1.2.19039273<28.1568202810;_gid=GA1.2.19039273<28.1568202810;_gid=GA1.2.19039273<28.1568202810;_gid=GA1.2.19039273<28.1568202810;_gid=GA1.2.19039273<28.1568202810; acct=t=YAiQ2RXtOBOG1Pf5UnKFxWZ%2bcINrjVde&s=%2btpIj7pF1GMoTVFuiDTS95VXolHih4l%2f; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499; _ym_uid=1565792005592706499
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}