import Foundation
let pattern = #""window_indicator":\s*([\-\d\.]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Line1\{"_check_id":"09b0f4e658a86000","_check_name":"Window status check","_level":"info","_measurement":"notifications","_message":"Check: Window status check is: info 0","_notification_endpoint_id":"09b162491aca8000","_notification_endpoint_name":"nc:8087","_notification_rule_id":"09b18e2dabebc000","_notification_rule_name":"Status is INFO notification rule (2m)","_source_measurement":"window_indicator","_source_timestamp":1658233200000000000,"_start":"2022-07-19T12:19:00Z","_status_timestamp":1658233200000000000,"_stop":"2022-07-19T12:22:00Z","_time":"2022-07-19T12:22:00Z","_type":"threshold","_version":1,"window_indicator":0}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}