$re = '/defining\s+\K[^;]+/m';
$str = 'defining var;
some text defining var;
some text defining var;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);