re = /[\{\}]\s*(\w+)(?=\s*\{)/
str = 'solvers
{
p
{
solver PCG;
preconditioner DIC;
tolerance 1e-06;
relTol 0.05;
}
q
{
solver PCG;
relTol 0.03;
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end