$re = '/(?<=.{7}).*$(*SKIP)(*F)|\D/';
$str = 'A12B345CD678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);