$re = '/טקסט([\s\S]*?)לכאן/m';
$str = 'טקסט כלשהו
שדגכשדגכ
שדגכ
שדגכ
שדגכ
שדגכ
שדג
שדגכ
עד לכאן';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);