import re
regex = re.compile(r"<trclass=\"odd\"><tdalign=\"left\"><ahref=\"https:\/\/3x\.projectnet\.de\/.{0,50}\/\"target=\"_blank\">(.{0,50})<\/a><\/td><td>(.{0,50})<\/td><tdalign=\"left\">.{0,50}<\/td><td><spanstyle=\"color:.{2,9};\">(.{2,10})<\/span><\/td><td>.{0,12}<\/td><td>.{0,12}<\/td><\/tr>")
test_str = "<!DOCTYPEHTMLPUBLIC\"-//W3C//DTDHTML4.0Transitional//EN\"><html><head><title>3XprojectnetÜbersicht</title><styletype=\"text/css\">body{font-size:9pt;font-family:Arial;text-decoration:none;}td{font-size:9pt;}##TABLE_DETAILS{border-collapse:collapse;background-color:##EEEEEE;};##TABLE_DETAILS.td{border:1pixsolid;}textarea{width:100%;height:210px;font-size:8pt;background-color:##EEEEEE}input{font-size:9pt;}</style><linkhref=\"templates_5/styles/sortabletable.css\"rel=\"stylesheet\"type=\"text/css\"media=\"all\"><scripttype=\"text/javascript\">application=newArray();application[\"uTemplates\"]=\"http://demo.projectnet.de/templates_5/\";session_urltoken=\"\";</script><scripttype=\"text/javascript\"src=\"templates_5/js/sortabletable.js\"></script></head><body><tablewidth=\"100%\"cellpadding=\"2\"cellspacing=\"0\"><trvalign=\"top\"><td>STATUS: <ahref=\"/uebersicht.cfm?nStatus=1\">AKTIV</a> <ahref=\"/uebersicht.cfm?nStatus=4\">GESPERRT</a> <strong>ARCHIVIERT</strong><br><br><tableclass=\"sort-table\"id=\"table-1\"cellspacing=\"1\"width=\"80%\"><thead><tr><td>Name</td><td>Pfad</td><td>DSN</td><td>DB-Status</td><td>Erstellt</td><td>LetzteAktivität</td></tr></thead><tbody><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_akademie/\"target=\"_blank\">3XAkademie</a></td><td>pn_3x_akademie</td><tdalign=\"left\">pn_3x_akademie</td><td><spanstyle=\"color:red;\">offline</span></td><td>02.05.11</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_vr_dresden/\"target=\"_blank\">DresdnerVolksbankRaiffeisenbankeG</a></td><td>pn_3x_vr_dresden</td><tdalign=\"left\">pn_3x_vr_dresden</td><td><spanstyle=\"color:red;\">offline</span></td><td>06.07.09</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_echterdinger_bank/\"target=\"_blank\">EchterdingerBankeG</a></td><td>pn_3x_echterdinger_bank</td><tdalign=\"left\">pn_3x_echterdinger_bank</td><td><spanstyle=\"color:red;\">offline</span></td><td>04.09.12</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_eckernfoerder_bank/\"target=\"_blank\">EckernförderBankeG</a></td><td>pn_3x_eckernfoerder_bank</td><tdalign=\"left\">pn_3x_eckernfoerder_bank</td><td><spanstyle=\"color:red;\">offline</span></td><td>05.12.11</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_foehr_amrum/\"target=\"_blank\">Föhr-AmrumerBankeG</a></td><td>pn_3x_foehr_amrum</td><tdalign=\"left\">pn_3x_foehr_amrum</td><td><spanstyle=\"color:red;\">offline</span></td><td>16.11.11</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_genopost/\"target=\"_blank\">GenoPost</a></td><td>pn_3x_genopost</td><tdalign=\"left\">pn_3x_genopost</td><td><spanstyle=\"color:red;\">offline</span></td><td>16.02.11</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_psdbank/\"target=\"_blank\">GUProjekte</a></td><td>pn_psdbank</td><tdalign=\"left\">pn_psdbank</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_gu_projekte/\"target=\"_blank\">GU-Projekte</a></td><td>pn_3x_gu_projekte</td><tdalign=\"left\">pn_3x_gu_projekte</td><td><spanstyle=\"color:green;\">online</span></td><td>18.11.14</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/NLP/\"target=\"_blank\">NLP</a></td><td>NLP</td><tdalign=\"left\">pn_NLP</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_nordthueringer_voba/\"target=\"_blank\">NordthüringerVolksbankeG</a></td><td>pn_3x_nordthueringer_voba</td><tdalign=\"left\">pn_3x_nordthueringer_voba</td><td><spanstyle=\"color:red;\">offline</span></td><td>12.01.11</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_raboroermond/\"target=\"_blank\">RabobankRoermond</a></td><td>pn_raboroermond</td><tdalign=\"left\">pn_raboroermond</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_raiba_aschberg/\"target=\"_blank\">RaiffeisenbankAschbergeG</a></td><td>pn_3x_raiba_aschberg</td><tdalign=\"left\">pn_3x_raiba_aschberg</td><td><spanstyle=\"color:green;\">online</span></td><td>08.05.12</td><td>04.03.14</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_burgebrach_stegaurach/\"target=\"_blank\">RaiffeisenbankBurgebrach-StegauracheG</a></td><td>pn_3x_burgebrach_stegaurach</td><tdalign=\"left\">pn_3x_burgebrach_stegaurach</td><td><spanstyle=\"color:red;\">offline</span></td><td>09.02.12</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_gefrees/\"target=\"_blank\">RaiffeisenbankGefreeseG</a></td><td>pn_3x_gefrees</td><tdalign=\"left\">pn_3x_gefrees</td><td><spanstyle=\"color:red;\">offline</span></td><td>13.07.10</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_rb_gundelfingen/\"target=\"_blank\">RaiffeisenbankGundelfingeneG</a></td><td>pn_3x_rb_gundelfingen</td><tdalign=\"left\">pn_3x_rb_gundelfingen</td><td><spanstyle=\"color:green;\">online</span></td><td>25.06.12</td><td>17.12.12</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_raiba_haibach_obernau/\"target=\"_blank\">RaiffeisenbankHaibach-ObernaueG</a></td><td>pn_3x_raiba_haibach_obernau</td><tdalign=\"left\">pn_3x_raiba_heibach_obernau</td><td><spanstyle=\"color:red;\">offline</span></td><td>19.03.12</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_haunetal/\"target=\"_blank\">RaiffeisenbankHaunetal</a></td><td>pn_haunetal</td><tdalign=\"left\">pn_haunetal</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_illerrothguenz/\"target=\"_blank\">RaiffeisenbankIller-Roth-GünzeG</a></td><td>pn_3x_illerrothguenz</td><tdalign=\"left\">pn_3x_illerrothguenz</td><td><spanstyle=\"color:red;\">offline</span></td><td>26.04.11</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_rb_rhein_berg/\"target=\"_blank\">RaiffeisenbankRhein-BergeG</a></td><td>pn_3x_rb_rhein_berg</td><tdalign=\"left\">pn_3x_rb_rhein_berg</td><td><spanstyle=\"color:red;\">offline</span></td><td>01.03.12</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_seebachgrund/\"target=\"_blank\">RaiffeisenbankSeebachgrundeG</a></td><td>pn_3x_seebachgrund</td><tdalign=\"left\">pn_3x_seebachgrund</td><td><spanstyle=\"color:red;\">offline</span></td><td>10.08.11</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_rbstegaurach/\"target=\"_blank\">RaiffeisenbankStegauracheG</a></td><td>pn_3x_rbstegaurach</td><tdalign=\"left\">pn_3x_rbstegaurach</td><td><spanstyle=\"color:red;\">offline</span></td><td>01.04.11</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_rv_schwabenheim/\"target=\"_blank\">Raiffeisen-VolksbankeG(Schwabenheim)</a></td><td>pn_3x_rv_schwabenheim</td><tdalign=\"left\">pn_3x_rv_schwabenheim</td><td><spanstyle=\"color:red;\">offline</span></td><td>21.01.10</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_raiba_lichtenfels_itzgrund/\"target=\"_blank\">Raiffeisen-VolksbankLichtenfels-ItzgrundeG</a></td><td>pn_3x_raiba_lichtenfels_itzgrund</td><tdalign=\"left\">pn_3x_raiba_lichtenfels_itzgrund</td><td><spanstyle=\"color:red;\">offline</span></td><td>11.03.13</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_rvb_neuburg_donau/\"target=\"_blank\">Raiffeisen-VolksbankNeuburg/DonaueG</a></td><td>pn_3x_rvb_neuburg_donau</td><tdalign=\"left\">pn_3x_rvb_neuburg_donau</td><td><spanstyle=\"color:green;\">online</span></td><td>25.10.12</td><td>28.07.14</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_gemuenden/\"target=\"_blank\">Spar-u.Kredit-BankeG(Gemünden)</a></td><td>pn_3x_gemuenden</td><tdalign=\"left\">pn_3x_gemuenden</td><td><spanstyle=\"color:green;\">online</span></td><td>26.07.11</td><td>08.05.13</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/SBHessen/\"target=\"_blank\">SpardaBankHessen</a></td><td>SBHessen</td><tdalign=\"left\">pn_SBHessen</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/SpardaBankBerlin_Projekte/\"target=\"_blank\">Sparda-BankBerlineG(AlleProjekte)</a></td><td>SpardaBankBerlin_Projekte</td><tdalign=\"left\">pn_SpardaBankBerlin_Projekte</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_sbb_sonne/\"target=\"_blank\">Sparda-BankBerlineG(Sonne)</a></td><td>pn_sbb_sonne</td><tdalign=\"left\">pn_sbb_sonne</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_skdetmold/\"target=\"_blank\">SparkasseDetmold</a></td><td>pn_skdetmold</td><tdalign=\"left\">pn_skdetmold</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_meinevvb/\"target=\"_blank\">VereinigteVolksbankeGDillingen-Dudweiler-Sulzb.</a></td><td>pn_3x_meinevvb</td><tdalign=\"left\">pn_3x_meinevvb</td><td><spanstyle=\"color:green;\">online</span></td><td>21.01.10</td><td>23.02.15</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_vrbprignitz/\"target=\"_blank\">Volks-undRaiffeisenbankPrignitzeG</a></td><td>pn_3x_vrbprignitz</td><tdalign=\"left\">pn_3x_vrbprignitz</td><td><spanstyle=\"color:red;\">offline</span></td><td>08.12.09</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/BeckumVolksbank/\"target=\"_blank\">VolksbankBeckumeG</a></td><td>BeckumVolksbank</td><tdalign=\"left\">pn_BeckumVolksbank</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/Neuerburg/\"target=\"_blank\">VolksbankBitburgeG</a></td><td>Neuerburg</td><tdalign=\"left\">pn_Neuerburg</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_voba_dill/\"target=\"_blank\">VolksbankDilleG</a></td><td>pn_3x_voba_dill</td><tdalign=\"left\">pn_3x_voba_dill</td><td><spanstyle=\"color:green;\">online</span></td><td>23.05.14</td><td>22.09.15</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_vobamosbach/\"target=\"_blank\">VolksbankeGMosbach</a></td><td>pn_vobamosbach</td><tdalign=\"left\">pn_vobamosbach</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_heiligenstadt/\"target=\"_blank\">VolksbankHeiligenstadteG</a></td><td>pn_heiligenstadt</td><tdalign=\"left\">pn_heiligenstadt</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_hellweg/\"target=\"_blank\">VolksbankHellwegeG</a></td><td>pn_hellweg</td><tdalign=\"left\">pn_hellweg</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_voba_heuberg/\"target=\"_blank\">VolksbankHeubergeG</a></td><td>pn_3x_voba_heuberg</td><tdalign=\"left\">pn_3x_voba_heuberg</td><td><spanstyle=\"color:red;\">offline</span></td><td>30.01.12</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_vobasaarburg/\"target=\"_blank\">VolksbankHochwald-SaarburgeG</a></td><td>pn_vobasaarburg</td><tdalign=\"left\">pn_vobasaarburg</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_voba_luebeck/\"target=\"_blank\">VolksbankLübeckeG</a></td><td>pn_3x_voba_luebeck</td><tdalign=\"left\">pn_3x_voba_luebeck</td><td><spanstyle=\"color:green;\">online</span></td><td>22.07.13</td><td>13.11.14</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_magdeburg/\"target=\"_blank\">VolksbankMagdeburg</a></td><td>pn_3x_magdeburg</td><tdalign=\"left\">pn_3x_magdeburg</td><td><spanstyle=\"color:green;\">online</span></td><td>15.04.09</td><td>31.03.15</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_marl_recklinghausen/\"target=\"_blank\">VolksbankMarl-RecklinghauseneG</a></td><td>pn_3x_marl_recklinghausen</td><tdalign=\"left\">pn_3x_marl_recklinghausen</td><td><spanstyle=\"color:red;\">offline</span></td><td>29.09.10</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_mittweida/\"target=\"_blank\">VolksbankMittweida</a></td><td>pn_mittweida</td><tdalign=\"left\">pn_mittweida</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_nordmuensterland/\"target=\"_blank\">VolksbankNordmünsterlandeG</a></td><td>pn_nordmuensterland</td><tdalign=\"left\">pn_nordmuensterland</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_oberberg/\"target=\"_blank\">VolksbankOberbergeG</a></td><td>pn_oberberg</td><tdalign=\"left\">pn_oberberg</td><td><spanstyle=\"color:red;\">offline</span></td><td>-</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_vrb_ismaning/\"target=\"_blank\">VolksbankRaiffeisenbankIsmaningeG</a></td><td>pn_3x_vrb_ismaning</td><tdalign=\"left\">pn_3x_vrb_ismaning</td><td><spanstyle=\"color:green;\">online</span></td><td>03.05.13</td><td>14.04.14</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_voba_wilhelmshaben/\"target=\"_blank\">VolksbankWilhelmshaveneG</a></td><td>pn_3x_voba_wilhelmshaben</td><tdalign=\"left\">pn_3x_voba_wilhelmshaben</td><td><spanstyle=\"color:red;\">offline</span></td><td>12.10.10</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_vr_bank/\"target=\"_blank\">VR-BankeG(Schopfheim)</a></td><td>pn_3x_vr_bank</td><tdalign=\"left\">pn_3x_vr_bank</td><td><spanstyle=\"color:red;\">offline</span></td><td>17.09.09</td><td>-</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_rhein_sieg/\"target=\"_blank\">VR-BankRhein-SiegeG</a></td><td>pn_3x_rhein_sieg</td><tdalign=\"left\">pn_3x_rhein_sieg</td><td><spanstyle=\"color:green;\">online</span></td><td>20.04.10</td><td>21.09.15</td></tr><trclass=\"odd\"><tdalign=\"left\"><ahref=\"https://3x.projectnet.de/pn_3x_VR_Schwam_Eder/\"target=\"_blank\">VR-BankSchwalm-Eder</a></td><td>pn_3x_VR_Schwam_Eder</td><tdalign=\"left\">pn_3x_VR_Schwam_Eder</td><td><spanstyle=\"color:red;\">offline</span></td><td>29.03.12</td><td>-</td></tr></tbody></table></td></tr></table><scripttype=\"text/javascript\">varst1=newSortableTable(document.getElementById(\"table-1\"),[\"CaseInsensitiveString\",\"CaseInsensitiveString\",\"CaseInsensitiveString\",\"DateTime\",\"DateTime\"]);//st1.sort();</script></body></html>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")