import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https://www.facebook.com/pages/(.*?)/(.*?)[^0-9]";
final String string = "\n"
+ "4.712><h3 class=\"r\"><a href=\"/url?q=https://www.facebook.com/pages/Valentina-James-Photography/111558567434%3Fhc_location%3Dufi&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAWCBQwAA&usg=AFQjCNH5lRwnWUddcP0qcCM-Csc-NdefJg\">Valentina James Photography</b> - Facebook</a></h3><div class=\"s\"><div class=\"kv\" style=\"margin-bottom:2px\"><cite>https://www.facebook.com/pages/...Photography</b>/111558567434?...</cite><div class=\"_nBb\"><div style=\"display:inline\" onclick=\"google.sham(this);\" aria-expanded=\"false\" aria-haspopup=\"true\" tabindex=\"0\" data-ved=\"0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChDsHQgVMAA\"><span class=\"_O0\"></span></div><div style=\"display:none\" class=\"am-dropdown-menu\" role=\"menu\" tabindex=\"-1\"><ul><li class=\"_Ykb\"><a class=\"_Zkb\" href=\"/url?q=http://webcache.googleusercontent.com/search%3Fq%3Dcache:_Z_I3Uux3V8J:https://www.facebook.com/pages/Valentina-James-Photography/111558567434%3Fhc_location%253Dufi%252Bsite:www.facebook.com/pages%2B%2522likes%2522%2Bcrown%2Bpoint,%2BIN%2Bphotographer%26hl%3Den%26%26ct%3Dclnk&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAgCBcwAA&usg=AFQjCNGXwRek9GCPfDpW3xsuGDw5k47ong\">Cached</a></li></ul></div></div></div><span class=\"st\">Valentina James Photography</b>, Crown Point</b>, IN. 635 likes</b> · 2 talking about this. "<br>\n"
+ "This is what I like about photographs. They're proof that once, even if...</span><br></div></div><div Array><h3 class=\"r\"><a href=\"/url?q=https://www.facebook.com/pages/Starboi-Lashley-Photography/614119055321286&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAWCBkwAQ&usg=AFQjCNFX62erQIqPaKkLxj4FDEjt9PL_sw\">Starboi Lashley Photography</b> - Facebook</a></h3><div class=\"s\"><div class=\"kv\" style=\"margin-bottom:2px\"><cite>https://www.facebook.com/pages/...Photography</b>/614119055321286</cite><div class=\"_nBb\"><div style=\"display:inline\" onclick=\"google.sham(this);\" aria-expanded=\"false\" aria-haspopup=\"true\" tabindex=\"0\" data-ved=\"0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChDsHQgaMAE\"><span class=\"_O0\"></span></div><div style=\"display:none\" class=\"am-dropdown-menu\" role=\"menu\" tabindex=\"-1\"><ul><li class=\"_Ykb\"><a class=\"_Zkb\" href=\"/url?q=http://webcache.googleusercontent.com/search%3Fq%3Dcache:R7xl4fzKH7MJ:https://www.facebook.com/pages/Starboi-Lashley-Photography/614119055321286%252Bsite:www.facebook.com/pages%2B%2522likes%2522%2Bcrown%2Bpoint,%2BIN%2Bphotographer%26hl%3Den%26%26ct%3Dclnk&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAgCBwwAQ&usg=AFQjCNGU3xDOIDxQL8j2SBgGNa0ZvGZ1DA\">Cached</a></li><li class=\"_Ykb\"><a class=\"_Zkb\" href=\"/search?ie=UTF-8&q=related:https://www.facebook.com/pages/Starboi-Lashley-Photography/614119055321286&tbo=1&sa=X&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAfCB0wAQ\">Similar</a></li></ul></div></div></div><span class=\"st\">1971 likes</b> · 19 talking about this · 1 was here. Contact ... Starboi Lashley <br>\n"
+ "Photography's</b> Profile Photo .... Location: Store Bay Local Road, Crown Point</b> <br>\n"
+ "Tobago.</span><br></div></div><div Array><h3 class=\"r\"><a href=\"/url?q=https://www.facebook.com/pages/John-Giolas-Photographers/71083285639&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAWCB8wAg&usg=AFQjCNFre1btFSQyPYiq5iB19OiccaEdfQ\">John Giolas Photographers</b> - Facebook</a></h3><div class=\"s\"><div class=\"kv\" style=\"margin-bottom:2px\"><cite>https://www.facebook.com/pages/John...Photographers</b>/71083285639</cite><div class=\"_nBb\"><div style=\"display:inline\" onclick=\"google.sham(this);\" aria-expanded=\"false\" aria-haspopup=\"true\" tabindex=\"0\" data-ved=\"0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChDsHQggMAI\"><span class=\"_O0\"></span></div><div style=\"display:none\" class=\"am-dropdown-menu\" role=\"menu\" tabindex=\"-1\"><ul><li class=\"_Ykb\"><a class=\"_Zkb\" href=\"/url?q=http://webcache.googleusercontent.com/search%3Fq%3Dcache:tpeP1k5Vy3cJ:https://www.facebook.com/pages/John-Giolas-Photographers/71083285639%252Bsite:www.facebook.com/pages%2B%2522likes%2522%2Bcrown%2Bpoint,%2BIN%2Bphotographer%26hl%3Den%26%26ct%3Dclnk&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAgCCIwAg&usg=AFQjCNEyUnAeEbcOhyEM6P5UWr3PxsLdtw\">Cached</a></li><li class=\"_Ykb\"><a class=\"_Zkb\" href=\"/search?ie=UTF-8&q=related:https://www.facebook.com/pages/John-Giolas-Photographers/71083285639&tbo=1&sa=X&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAfCCMwAg\">Similar</a></li></ul></div></div></div><div class=\"f slp\"><div class=\"star\"><div style=\"width:65px\"> </div></div> Rating: 5 - 2 votes</div><span class=\"st\">John Giolas Photographers</b>, Merrillville, Indiana. 110 likes</b> · 37 were here. ... <br>\n"
+ "contact Anna Blackmon Photography</b> on Broadway in Crown Point</b> at 219-226-<br>\n"
+ "1777.</span><br></div></div><div Array><h3 class=\"r\"><a href=\"/url?q=https://www.facebook.com/pages/on-Broadway-in-Crownpoint-IN/233362890037558&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAWCCYwAw&usg=AFQjCNH1lcQrZXHdqTOw-fzIPNW5CXJKTg\">on Broadway in Crownpoint</b>, IN - Crown Point</b>, Indiana - Arts ...</b></a></h3><div class=\"s\"><div class=\"kv\" style=\"margin-bottom:2px\"><cite>https://www.facebook.com/pages/...Crownpoint</b>.../233362890037558</cite><div class=\"_nBb\"><div style=\"display:inline\" onclick=\"google.sham(this);\" aria-expanded=\"false\" aria-haspopup=\"true\" tabindex=\"0\" data-ved=\"0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChDsHQgnMAM\"><span class=\"_O0\"></span></div><div style=\"display:none\" class=\"am-dropdown-menu\" role=\"menu\" tabindex=\"-1\"><ul><li class=\"_Ykb\"><a class=\"_Zkb\" href=\"/url?q=http://webcache.googleusercontent.com/search%3Fq%3Dcache:EH-vRnMpbZ8J:https://www.facebook.com/pages/on-Broadway-in-Crownpoint-IN/233362890037558%252Bsite:www.facebook.com/pages%2B%2522likes%2522%2Bcrown%2Bpoint,%2BIN%2Bphotographer%26hl%3Den%26%26ct%3Dclnk&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAgCCkwAw&usg=AFQjCNEWREAjgeUMb7L6IeHwqWd28Et3Og\">Cached</a></li></ul></div></div></div><span class=\"st\">on Broadway in Crownpoint</b>, IN, Crown Point</b>, Indiana. 2 likes</b> · 5 were here. ... <br>\n"
+ "Sacred Life Photography</b> added a new photo — with Edward Frey III and 2 others<br>\n"
+ " ...</span><br></div></div><div Array><h3 class=\"r\"><a href=\"/url?q=https://www.facebook.com/pages/Lofs-Clubhouse/123172094425087&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAWCCswBA&usg=AFQjCNFtu-NuNKa_f4nqGkcYbUjQSnEubA\">Lofs Clubhouse - Crown Point</b>, Indiana - Local Business | Facebook</a></h3><div class=\"s\"><div class=\"kv\" style=\"margin-bottom:2px\"><cite>https://www.facebook.com/pages/Lofs.../123172094425087</cite><div class=\"_nBb\"><div style=\"display:inline\" onclick=\"google.sham(this);\" aria-expanded=\"false\" aria-haspopup=\"true\" tabindex=\"0\" data-ved=\"0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChDsHQgsMAQ\"><span class=\"_O0\"></span></div><div style=\"display:none\" class=\"am-dropdown-menu\" role=\"menu\" tabindex=\"-1\"><ul><li class=\"_Ykb\"><a class=\"_Zkb\" href=\"/url?q=http://webcache.googleusercontent.com/search%3Fq%3Dcache:p-9xlGkO7_QJ:https://www.facebook.com/pages/Lofs-Clubhouse/123172094425087%252Bsite:www.facebook.com/pages%2B%2522likes%2522%2Bcrown%2Bpoint,%2BIN%2Bphotographer%26hl%3Den%26%26ct%3Dclnk&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAgCC4wBA&usg=AFQjCNH4AEX37eL344djiRxrIeHre7SZuQ\">Cached</a></li></ul></div></div></div><div class=\"f slp\"><div class=\"star\"><div style=\"width:39px\"> </div></div> Rating: 2.8 - 11 votes</div><span class=\"st\">Local Business · Crown Point</b>, IN, United States. · 2.8 ☆. 626 people checked ... <br>\n"
+ "Jill Marie Photography</b> with Sally Lugo at Lofs Clubhouse. December 20, 2015 ...</span><br></div></div><div Array><h3 class=\"r\"><a href=\"/url?q=https://www.facebook.com/pages/Glimpses-Photography-By-Louise-Roys/149619258165%3Ffref%3Dts&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAWCDEwBQ&usg=AFQjCNGJGkjgjOe9nt-WuGV00Vih7kk2jA\">Glimpses Photography</b> By Louise Roys - Facebook</a></h3><div class=\"s\"><div class=\"kv\" style=\"margin-bottom:2px\"><cite>https://www.facebook.com/pages/...Photography</b>.../149619258165?...</cite><div class=\"_nBb\"><div style=\"display:inline\" onclick=\"google.sham(this);\" aria-expanded=\"false\" aria-haspopup=\"true\" tabindex=\"0\" data-ved=\"0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChDsHQgyMAU\"><span class=\"_O0\"></span></div><div style=\"display:none\" class=\"am-dropdown-menu\" role=\"menu\" tabindex=\"-1\"><ul><li class=\"_Ykb\"><a class=\"_Zkb\" href=\"/url?q=http://webcache.googleusercontent.com/search%3Fq%3Dcache:MC7JcrpIQYoJ:https://www.facebook.com/pages/Glimpses-Photography-By-Louise-Roys/149619258165%3Ffref%253Dts%252Bsite:www.facebook.com/pages%2B%2522likes%2522%2Bcrown%2Bpoint,%2BIN%2Bphotographer%26hl%3Den%26%26ct%3Dclnk&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAgCDQwBQ&usg=AFQjCNGsmHnnlrh2QcaiDsmTQ7dg8h4mtQ\">Cached</a></li></ul></div></div></div><div class=\"f slp\"><div class=\"star\"><div style=\"width:59px\"> </div></div> Rating: 4.7 - 3 votes - Price range: $$$$</div><span class=\"st\">153 likes</b> · 10 talking about this · 10 were here. Photography</b> and Video. ... '<br>\n"
+ "Saturday November 28, 2015 10am- 4 pm Winter Market Crown Point</b> Court <br>\n"
+ "House.</span><br></div></div><div Array><h3 class=\"r\"><a href=\"/url?q=https://www.facebook.com/pages/Dawn-Michelle-Photography/467704393348290&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAWCDcwBg&usg=AFQjCNEn8kxFG5mPlyk9__1ikuaxwHntvw\">Dawn Michelle Photography</b> - Facebook</a></h3><div class=\"s\"><div class=\"kv\" style=\"margin-bottom:2px\"><cite>https://www.facebook.com/pages/...Photography</b>/467704393348290</cite><div class=\"_nBb\"><div style=\"display:inline\" onclick=\"google.sham(this);\" aria-expanded=\"false\" aria-haspopup=\"true\" tabindex=\"0\" data-ved=\"0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChDsHQg4MAY\"><span class=\"_O0\"></span></div><div style=\"display:none\" class=\"am-dropdown-menu\" role=\"menu\" tabindex=\"-1\"><ul><li class=\"_Ykb\"><a class=\"_Zkb\" href=\"/url?q=http://webcache.googleusercontent.com/search%3Fq%3Dcache:atWTKZA6Sy4J:https://www.facebook.com/pages/Dawn-Michelle-Photography/467704393348290%252Bsite:www.facebook.com/pages%2B%2522likes%2522%2Bcrown%2Bpoint,%2BIN%2Bphotographer%26hl%3Den%26%26ct%3Dclnk&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAgCDowBg&usg=AFQjCNGAeryiRVv8myRtbwiJv0oRWXPVdA\">Cached</a></li></ul></div></div></div><div class=\"f slp\"><div class=\"star\"><div style=\"width:65px\"> </div></div> Rating: 5 - 21 votes</div><span class=\"st\">Dawn Michelle Photography</b>, Crown Point</b>, Indiana. 404 likes</b> · 21 talking about <br>\n"
+ "this · 4 were here. Photography</b> for all memories. Senior Photos, Family...</span><br></div></div><div Array><h3 class=\"r\"><a href=\"/url?q=https://www.facebook.com/pages/Lemon-Lake/180356962010907&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAWCD0wBw&usg=AFQjCNFLD3Tcc3n3rXtaorIRt1m2w3kJMw\">Lemon Lake - Crown Point</b>, Indiana - Park | Facebook</a></h3><div class=\"s\"><div class=\"kv\" style=\"margin-bottom:2px\"><cite>https://www.facebook.com/pages/Lemon-Lake/180356962010907</cite><div class=\"_nBb\"><div style=\"display:inline\" onclick=\"google.sham(this);\" aria-expanded=\"false\" aria-haspopup=\"true\" tabindex=\"0\" data-ved=\"0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChDsHQg-MAc\"><span class=\"_O0\"></span></div><div style=\"display:none\" class=\"am-dropdown-menu\" role=\"menu\" tabindex=\"-1\"><ul><li class=\"_Ykb\"><a class=\"_Zkb\" href=\"/url?q=http://webcache.googleusercontent.com/search%3Fq%3Dcache:QuetdaMmnAgJ:https://www.facebook.com/pages/Lemon-Lake/180356962010907%252Bsite:www.facebook.com/pages%2B%2522likes%2522%2Bcrown%2Bpoint,%2BIN%2Bphotographer%26hl%3Den%26%26ct%3Dclnk&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAgCEAwBw&usg=AFQjCNHfRdodCWt-jE0GhqsfG-93-WsUXA\">Cached</a></li></ul></div></div></div><span class=\"st\">·Located in Crown Point</b>, Indiana. Lemon Lake ... Park · Crown Point</b>, IN, United <br>\n"
+ "States ... Meta Photography</b> added a new photo — at Lemon Lake. August 2 ...</span><br></div></div><div Array><h3 class=\"r\"><a href=\"/url?q=https://www.facebook.com/pages/Meta-Photography/143568095781826&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAWCEIwCA&usg=AFQjCNFaJevdUOgRPote5Fu3f3zbvwvH5g\">Meta Photography</b> - Facebook</a></h3><div class=\"s\"><div class=\"kv\" style=\"margin-bottom:2px\"><cite>https://www.facebook.com/pages/...Photography</b>/143568095781826</cite><div class=\"_nBb\"><div style=\"display:inline\" onclick=\"google.sham(this);\" aria-expanded=\"false\" aria-haspopup=\"true\" tabindex=\"0\" data-ved=\"0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChDsHQhDMAg\"><span class=\"_O0\"></span></div><div style=\"display:none\" class=\"am-dropdown-menu\" role=\"menu\" tabindex=\"-1\"><ul><li class=\"_Ykb\"><a class=\"_Zkb\" href=\"/url?q=http://webcache.googleusercontent.com/search%3Fq%3Dcache:sxAahcatlpUJ:https://www.facebook.com/pages/Meta-Photography/143568095781826%252Bsite:www.facebook.com/pages%2B%2522likes%2522%2Bcrown%2Bpoint,%2BIN%2Bphotographer%26hl%3Den%26%26ct%3Dclnk&sa=U&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAgCEUwCA&usg=AFQjCNGaXFCjzKwrqo8_kEK5Gwl-SAvxJg\">Cached</a></li><li class=\"_Ykb\"><a class=\"_Zkb\" href=\"/search?ie=UTF-8&q=related:https://www.facebook.com/pages/Meta-Photography/143568095781826&tbo=1&sa=X&ved=0ahUKEwiqi9yD3sDLAhUmkoMKHXomA6s4ChAfCEYwCA\">Similar</a></li></ul></div></div></div><div class=\"f slp\"><div class=\"star\"><div style=\"width:52px\"> </div></div> Rating: 4.2 - 18 votes</div><span class=\"st\">Meta Photography</b>, Schererville, Indiana. 332 likes</b> · 5 were here. Phtotography <br>\n"
+ "has always been a passion of mine. As a kid i walked around with those...</span><br></div></div><div Array";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}