#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)^" & @CRLF & _
"(" & @CRLF & _
"(?:[a-z\d."_-](?<!\.{2}))+" & @CRLF & _
")" & @CRLF & _
"(@)" & @CRLF & _
"(" & @CRLF & _
"(?:(?!-)[a-z\d_-]*(?<!-))+" & @CRLF & _
"(?:\.(?!-)[a-z\d_-]*(?<!-))+" & @CRLF & _
")" & @CRLF & _
"$"
Local $sString = ".aza.aa","zk.k.kk@a-a-a-a-a-a.a-5.123123.aaaaa.a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")