re = /(?:start:(?=\w+(?:-\w+){2,9}:end)|(?<=-)\G)(\w+)(?:-|:end)/
str = 'start:test-test-lorem-ipsum-sir-doloret-etc-something:end'
# Print the match result
str.match(re) do |match|
puts match.to_s
end