$re = '/[^|\w](\w+([-+.\']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*)/m';
$str = '|данные|данные|moy_mail@mail.ru|данные|данные|Текст_материала_статьи ... (в тексте вставлен e-mail@mail.ru) ... какой-то текст...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);