# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)(^l(?:ol){2,}$|^troll$|tejveer ?iq|ser?vice pemanas?|\bnigg[aeu][rh]?|\b(fuck(er|ing)?|penis)\b|^wingding$|dlqudals|^[a-z ]+juri(?:n|na|ns|sa|ya|yam|ym)$|^[a-z]+jiibond$)"
test_str = ("lolololol\n"
"troll\n"
"random tejveer iq random \n"
"random sevice pemanarandom\n"
"random nigger nigguh random\n"
"random fucking penis random\n"
"wingding\n"
"random dlqudals random\n"
"randomjuriym\n"
"randomjiibond\n"
"# No match\n"
"random lololol\n"
"lololol random\n"
"random troll\n"
"sniggering\n"
"dompenism is not a word\n"
"random space juryim\n"
"juryims\n"
"random space jiibond\n"
"jiibonds")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.