re = /\d+(?:-\d+)? \K.+(?= )/m
str = '23 Barrel Rd.
14 Old Mill Dr.
65-345 Howard\'s Bluff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end