# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:APR|April)\ *\d+(?:[nr]d|th|st)?(?:-\d+(?:[nr]d|th|st)?)?|\d+(?:[nr]d|th|st)?(?:-\d+(?:[nr]d|th|st)?)?\ *(?:APR|April)"
test_str = ("some garbagde . some garbagde 02 APR some garbagde\n"
"some garbagde . some garbagde APR 02 some garbagde \n"
"some garbagde . some garbagde 2 APR some garbagde\n"
"some garbagde . some garbagde APR 2 some garbagde\n"
"some garbagde . some garbagde 2nd APR some garbagde\n"
"some garbagde . some garbagde APR 2nd some garbagde\n"
"some garbagde . some garbagde 2nd April some garbagde\n"
"some garbagde . some garbagde April 2nd some garbagde\n"
"some garbagde . some garbagde APR 12th some garbagde\n"
"some garbagde . April 12th some garbagde\n"
"some garbagde . 12th April some garbagde\n"
"some garbagde . April 13-16 some garbagde\n"
"some garbagde . 13-16 April some garbagde\n"
"some garbagde . APR 13-16 some garbagde\n"
"some garbagde . 13-16 APR some garbagde\n"
"some garbagde . April 13th-16th some garbagde\n"
"some garbagde . 13th-16th April some garbagde\n"
"some garbagde . APR 13th-16th some garbagde\n"
"some garbagde . 13th-16th APR some garbagde")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.