import re
regex = re.compile(r"\[(\d{2}:\d{2}:\d{2})] \[(.*)\/(INFO|WARN|ERROR|FATAL)]( \[.*])*:((?:.*\n(?!\[\d{2}:\d{2}:\d{2}]))*.*)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("[14:41:43] [Server thread/INFO] [journeymap]: meaneea joining dimension -1\n"
"[14:41:43] [Server thread/INFO] [Mekanism]: Sent config to 'meaneea.'\n"
"[14:41:43] [Server thread/ERROR] [FML]: FMLIndexedMessageCodec exception caught\n"
"io.netty.handler.codec.EncoderException: java.lang.RuntimeException: Undefined discriminator for message type com.github.lunatrius.ingameinfo.network.message.MessageSeed in channel ingameinfoxml\n"
" at io.netty.handler.codec.MessageToMessageEncoder.write(MessageToMessageEncoder.java:106) ~[minecraft_server.1.12.2.jar:?]\n"
" at io.netty.handler.codec.MessageToMessageCodec.write(MessageToMessageCodec.java:116) ~[minecraft_server.1.12.2.jar:?]\n"
" at io.netty.channel.AbstractChannelHandlerContext.invokeWrite0(AbstractChannelHandlerContext.java:738) ~[minecraft_server.1.12.2.jar:?]\n"
" at io.netty.channel.AbstractChannelHandlerContext.invokeWriteAndFlush(AbstractChannelHandlerContext.java:801) ~[minecraft_server.1.12.2.jar:?]\n"
" at io.netty.channel.AbstractChannelHandlerContext.write(AbstractChannelHandlerContext.java:814) ~[minecraft_server.1.12.2.jar:?]\n"
" at io.netty.channel.AbstractChannelHandlerContext.writeAndFlush(AbstractChannelHandlerContext.java:794) ~[minecraft_server.1.12.2.jar:?]\n"
" at io.netty.channel.AbstractChannelHandlerContext.writeAndFlush(AbstractChannelHandlerContext.java:831) ~[minecraft_server.1.12.2.jar:?]\n"
" at io.netty.channel.DefaultChannelPipeline.writeAndFlush(DefaultChannelPipeline.java:1032) ~[minecraft_server.1.12.2.jar:?]\n"
" at io.netty.channel.AbstractChannel.writeAndFlush(AbstractChannel.java:296) ~[minecraft_server.1.12.2.jar:?]\n"
" at net.minecraftforge.fml.common.network.simpleimpl.SimpleNetworkWrapper.sendTo(SimpleNetworkWrapper.java:250) [SimpleNetworkWrapper.class:?]\n"
" at com.github.lunatrius.ingameinfo.handler.PlayerHandler.onPlayerLogin(PlayerHandler.java:15) [PlayerHandler.class:?]\n"
" at net.minecraftforge.fml.common.eventhandler.ASMEventHandler_564_PlayerHandler_onPlayerLogin_PlayerLoggedInEvent.invoke(.dynamic) [?:?]\n"
" at net.minecraftforge.fml.common.eventhandler.ASMEventHandler.invoke(ASMEventHandler.java:90) [ASMEventHandler.class:?]\n"
" at net.minecraftforge.fml.common.eventhandler.EventBus.post(EventBus.java:182) [EventBus.class:?]\n"
" at net.minecraftforge.fml.common.FMLCommonHandler.firePlayerLoggedIn(FMLCommonHandler.java:575) [FMLCommonHandler.class:?]\n"
" at net.minecraft.server.management.PlayerList.initializeConnectionToPlayer(PlayerList.java:219) [pl.class:?]\n"
" at shadows.fastbench.net.HijackedDedicatedPlayerList.initializeConnectionToPlayer(HijackedDedicatedPlayerList.java:19) [HijackedDedicatedPlayerList.class:?]\n"
" at net.minecraftforge.fml.common.network.handshake.NetworkDispatcher.completeServerSideConnection(NetworkDispatcher.java:255) [NetworkDispatcher.class:?]\n"
" at net.minecraftforge.fml.common.network.handshake.NetworkDispatcher.access$100(NetworkDispatcher.java:72) [NetworkDispatcher.class:?]\n"
" at net.minecraftforge.fml.common.network.handshake.NetworkDispatcher$1.func_73660_a(NetworkDispatcher.java:205) [NetworkDispatcher$1.class:?]\n"
" at net.minecraft.network.NetworkManager.func_74428_b(NetworkManager.java:285) [gw.class:?]\n"
" at net.minecraft.network.NetworkSystem.func_151269_c(NetworkSystem.java:180) [oz.class:?]\n"
" at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:790) [MinecraftServer.class:?]\n"
" at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:397) [nz.class:?]\n"
" at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:668) [MinecraftServer.class:?]\n"
" at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:526) [MinecraftServer.class:?]\n"
" at java.lang.Thread.run(Unknown Source) [?:1.8.0_291]\n"
"Caused by: java.lang.RuntimeException: Undefined discriminator for message type com.github.lunatrius.ingameinfo.network.message.MessageSeed in channel ingameinfoxml\n"
" at net.minecraftforge.fml.common.network.FMLIndexedMessageToMessageCodec.encode(FMLIndexedMessageToMessageCodec.java:76) ~[FMLIndexedMessageToMessageCodec.class:?]\n"
" at io.netty.handler.codec.MessageToMessageCodec$1.encode(MessageToMessageCodec.java:67) ~[minecraft_server.1.12.2.jar:?]\n"
" at io.netty.handler.codec.MessageToMessageEncoder.write(MessageToMessageEncoder.java:88) ~[minecraft_server.1.12.2.jar:?]\n"
" ... 26 more\n"
"[14:41:43] [Server thread/INFO] [journeymap]: Sending log in packet.\n"
"[14:41:43] [Server thread/INFO] [ViesCraft]: Logged in Server\n"
"[14:45:07] [Server thread/INFO] [journeymap]: meaneea joining dimension 0\n"
"[14:45:08] [Server thread/INFO] [FML]: Unloading dimension -1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")