re = /(?=.*(?<one>foo))(?=.*(?<two>bar))(?=.*(?<three>baz))/m
str = 'foo bar baz
foo baz bar
baz bar foo
foo bar
foo baz
bar baz
foo
bar
baz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end