$re = '/.*(\d).*\1/m';
$str = '123456788
123456789
123456711
123956789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);