const regex = /^(.*?)(\*[0-9]+\s?)+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)(\\*[0-9]+\\s?)+$', '')
const str = `Just some blablabla with some notes on the end *1 *2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}